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What This Tutorial Does
This tutorial has basic information about using three OpenOffice built-in Paragraph Styles 
called “Heading 1”, “Heading 2” and “Heading 3” to format a document and create a Table Of 
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Contents.  Additional entries are added to the Table Of Contents. 

Why There Are Columns And Words In Bold
To make the tutorial easier to read and to use the same tutorial for both advanced and 
beginner students, the content in parenthesis ( )  provides extra help for first-time users and 
shows them what happens on their screen when they perform the actions.  Bold is used so 
that certain words stand out; for example, words to be clicked or to be typed are in bold.  To 
understand the lesson, advanced students may prefer to skim the content and perform the 
actions specified in bold.

Results Of This Tutorial
The results of following this tutorial may be downloaded from the website by clicking on the 
word, here, which is blue and underlined and located beside the name of this tutorial on the 
Writer web page.  It may be helpful to keep that page available as this lesson is being done. 

Basic Information
OpenOffice comes with Paragraph Styles named “Heading 1”, Heading 2”, Heading 3“, etc. 
These numbered  “Heading” Paragraph Styles are used to create a Table Of Contents.  

Apply The "Heading 1" Paragraph Style For "My Classes"
1. Click File  >   New   >   Text Document.  (The  

document appears.)
2. Type the words, My Classes.
3. Click Format > Styles and Formatting.  (The “Styles and Formatting” window 

appears.)  Click on the Paragraph Styles,   icon.  (Place your cursor on each icon, 
the small pictures, to find 'Paragraph Styles'.)

4. In the Paragraph Styles window, double-click Heading 1. (A heading or sub-title 
above a paragraph is considered part of a paragraph.  Double-clicking "Heading 1" 
activates the “Heading 1” Paragraph Style which is displayed in the  “Apply Styles” 
dialog box ,  , on the Formatting Toolbar (the third line from the top 
of the screen.  The words “My Classes” become bigger and bold. The Paragraph Style 
“Heading 1” automatically applies the font type Arial, font size 16, and Bold.  These 
settings can also be seen on the Formatting Toolbar.)
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Modify The "Heading 1" Paragraph Style
The settings of a Paragraph Style can be changed at any time.  

1. In the Paragraph Styles window, right-click on Heading 1,  (Right-click means to use 
the right side mouse button, not the usual left side button.  You will see the small 
menu .)   

2. Click the Modify button,  (The “Paragraph Style: Heading 1” window appears.)
3. Click the Font tab. If it is not already selected/highlighted, click  Arial (Font) >  Bold 

(Typeface) > 16 pt. (Size).  (The “Size” may be specified in percent or in points. To 
change from percent to points, delete the number in the upper  “Size” box and type a 
number followed by the letters, pt., such as 25pt. To change from points to  percent, 
delete the “Size” number and type a number followed by the percent symbol such as 
25%.  These settings can also be seen on the "Formatting Toolbar" which is the third 
line from the top of the screen.)

4. Click the Alignment tab.  In the Options section, select (click on) the word Center.  (A 
dot appears before the word “Center” indicating that “Center” has been selected.) 
Click OK.   (The words, “My Classes”, move to the center of the line, appear in bold, 
and are 20 pt.) 

Add Paragraphs After "My Classes"
1. Press the Enter key.  The Text body  Paragraph Style is activated. (The words “Text 

body” appear in the “Apply Styles” dialog box.  The cursor moves down two lines. The 
“Text body” font type is Arial, the font size is 12 and Bold is not in use.)

2. Type the words, I go to many classes.
3. Press Enter.  (The cursor moves down two lines.   When the "Enter" key is pressed in 

the text body Style, a new paragraph is started.)
4. Type the words, These are my classes.  

Modify And Apply the Heading 2 Paragraph Style For "English"
1. Press Enter.
2. Type the word, English.
3. In the Paragraph Styles window, right-click on Heading 2,  (You will see the small 

menu .)   

4. Click the Modify button,  (The “Paragraph Style: Heading 2” window appears.)
5. Click the Font tab.  If it is not already selected/highlighted, click  Arial ("ont) >  Bold 

(Typeface) > 14 pt. (Size).  (The “Size” may be specified in percent or in points. To 
change from percent to points, delete the number in the upper  “Size” box and type a 
number followed by the letters, pt., such as 25pt. To change from points to  percent, 
delete the “Size” number and type a number followed by the percent symbol such as 
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25%.)
6. Click the Alignment tab.  In the Options section, click on the word, Left.   (A dot 

appears before the word, “Left”, indicating that “Left” has been selected.)  Click OK.
7. Click the Indent & Spacing tab.  In the Indent section, in the “Before text” dialog box, 

type .50.  ( (To change the numbers in the dialog box, click repeatedly on the    until 
".50” appears in the “Left” dialog or you can highlight the numbers and type ".50" or 
press Delete enough times to delete the number and type the number.  When the 
“Heading 2” Paragraph Style is activated, the words will be indented ½ of an inch.)

8. Double-click Heading 2. (This activates the “Heading 2” Paragraph Style.   “Heading 
2” appears in the “Apply Styles” dialog box.) 

Modify And Apply the "Heading 3" Paragraph Style For "Verbs"
1. Press Enter.
2. Type the word, Verbs.
3. In the Paragraph Styles window, right-click on Heading 3,  (You will see the small 

menu .)   

4. Click the Modify button,  (The “Paragraph Style: Heading 3” window appears.)
5. Click the Indent & Spacing tab.  In the Indent section, in the Before text dialog box, 

type 1.0.   (To change the numbers in the dialog box, click repeatedly on the    until 
1.0” appears in the “Left” dialog or you can highlight the numbers and type 1.0" or 
press Delete enough times to delete the number and type the number.  When the 
“Heading 3” Paragraph Style is activated, the words will be indented an inch.)

6. Click the Alignment tab, if it is not already selected, click Left.  Click the Font tab. If it 
is not already selected/highlighted, click  Arial (Font) >  Bold ( Typeface) > 14 pt. 
(Size) > OK.  (The “Size” may be specified in percent or in points. To change from 
percent to points, delete the number in the upper  “Size” box and type a number 
followed by the letters, pt., such as 25pt. To change from points to  percent, delete the 
“Size” number and type a number followed by the percent symbol such as 25%.)

7. Double-click Heading 3.  (The word “Verbs” moves to the right.  The line is indented 1 
inch.)

Add  Paragraphs After "Verbs"
1. Press the Enter key.  (The cursor moves down two lines.  The Paragraph Style “Text 

body” is in effect.)
2. Type the words, Some verbs are active then Press Enter. (The cursor moves down 

two lines.)
3. Type the words, Some verbs are not active.
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Apply The Heading 3 Paragraph Style For "Nouns"
1. Press the Enter key then type the word, Nouns.
2. Double-click  Heading 3. (The word “Nouns” is indented and is in bold.)

Add Two Paragraphs After "Nouns"
1. Press Enter then type the words, A person is a noun.
2. Press Enter then type the words, A place is a noun.

Apply The Heading 3 Paragraph Style For "Paragraphs"
1. Press the Enter key then type the word, Paragraphs.
2. Double-click  Heading 3. (The word, “Paragraphs”, is indented and is in bold.)

Add Paragraphs After the Heading 3 Paragraph Style, 
"Paragraphs"

1. Press Enter.
2. Type the words, This is a paragraph, then press Enter.
3. Type the words, This is also a paragraph.

Add More Paragraphs After The Heading 3 Paragraph Style, 
"Paragraphs"

1. Press Enter then type the words, This is a first paragraph.
2. Press Enter then type the words, This is the second paragraph.

Apply The "Heading 2" Paragraph Style For "Math"
1. Press Enter then type the word, Math.
2. Double-click Heading 2.  (The word, "Math", is indented and is in bold.)

Add One Paragraph After the Heading 2 Paragraph Style, 
"Math"

1. Press the Enter key.
2. Type the words, Math has many parts.

Apply The Heading 3 Paragraph Style For "Addition"
1. Press Enter then type the word, Addition.
2. Double-click Heading 3. ("Addition" is indented and is in bold.)
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Add A Paragraph After "Addition"
1. Press the Enter key.
2. Type the words, One plus one equals two.

Apply The Heading 3 Paragraph Style For "Subtraction"
1. Press Enter then type the word, Subtraction.
2. Double-click Heading 3.

Add A Paragraph After The Heading 2 Paragraph Style, 
Subtraction

1. Press the Enter key.
2. Type the words, Four minus two equals two.

Create A Table Of Contents
A Table of Contents is done after you complete your document.  The headings and sub-
headings in your document become the entries in the Table of Contents. 

1. Click after the last word in the title of the document,  just after the words, My Classes. 
(The flashing cursor appears after the letter “s”.)

2. Click Insert > Indexes & Tables >  Indexes & Tables.   (The “Insert Index/Table” 
window appears.)

3. Select the Index/Table tab, if it is not already selected.  In the Type dialog  box , select 
Table Of Contents, if it is not already selected.  Uncheck Protected against manual 
changes.  Click OK.  (The "Table of Contents" appears under the title of your 
document.)

Modify And Apply the Contents Heading Paragraph Style
1. Click Index Styles in the dialog box at the bottom of the Paragraph Styles window. 

Scroll down to Contents Heading.  (If the "Styles and Formatting" window is closed, 
click "Format > Styles and Formatting". To scroll down, put the pointer of the mouse on 
the     and keep clicking on the   until the words, “Contents Heading”, appear at 
the top of the list.)

2. In the Paragraph Styles window, right-click on Contents Heading,  (You will see the 
small  menu .)   

3. Click the Modify button,  (The “Paragraph Style: Contents Heading” window appears.)
4. Click the Alignment tab.  (The “Alignment” window appears.)  In the “Options” section, 

click on the word, Center.  (A dot appears before the word, “Center” indicating that 
“Center” has been selected.)  Click the “Font” tab (The “Font” window appears.) and 
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then click “Arial”, “Bold” and 14pt. > OK.  (The “Size” may be specified in percent or in 
points. To change from percent to points, delete the number in the upper  “Size” box 
and type a number followed by the letters, pt., such as 25pt. To change from points to 
percent, delete the “Size” number and type a number followed by the percent symbol 
such as 25%.)

5. Double-click Contents Heading.  (This activates the “Contents Heading” Paragraph 
Style.   “Contents Heading” appears in the “Apply Styles” dialog box.  The words, 
“Table Of Contents”, move to the center of the line.)

6. Close the Styles and Formatting window.  (Click on the X in the box in the upper right 
corner of the window.)

Add More Entries Into The "Table Of Contents"
Any part of the document may be added to the "Table Of Contents".

1. Highlight (select) the words,  second paragraph.   (Put the cursor just before the letter 
“s” then press and hold down the Shift key then press the right-facing arrow key until 
both words are selected [have a black background].)

2. Click Insert > Indexes and Tables > Entry.  (The “Insert Index Entry” window 
appears.  In the “Entry” box are the words “second paragraph”.)

3. In the “Index” box, select Table of Contents, if it is not already there,
4. In the “Level” box select 4.
5. Click the Insert button.  
6. Drag the “Insert Index Entry” window out of the way.  (Put the cursor anywhere on the 

top blue line of the window.  Press and hold down the left button of the mouse then 
move the mouse in the same direction as the window is to be moved.  Release the 
mouse  button when the window is in the desired location.)

7. Select the words, first paragraph” then click anywhere in the Entry box.  (The words 
“first paragraph” appear in the “Entry” box.)

8. In the “Level” box, select 4.
9. Click Insert > Close.

Update The Table Of Contents
Any time a change is made that is included in the Table Of Contents, the Table Of Contents 
must be updated.  Update the Table Of Contents as follows:

1. Right-click anywhere within the Table Of Contents.  (A menu appears.)
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2. Click Update Index/table.  (The words “second paragraph” and “first paragraph” 
appear in the Table Of Contents.)   

Change An Entry Already In The Table Of Contents

Change a Heading
1. Make the changes in the heading.  
2. Right-click anywhere within the Table Of Contents.  Click Update index/table.  (The 

entry in the "Table of Contents" changes.) 

Editing or Deleting Entries in The Table of Contents
Index entries are inserted as fields into your document. To view fields in your document, 
choose View and ensure that Field Shadings is selected. 

1. Place your cursor immediately in front of the index entry in your document, second 
paragraph. (The "Edit Index Entry" window appears.)

2. Right-click on the entry.  Choose Index Entry, in the Entry box, type third 
paragraph.  ("second paragraph" is in the "Entry" box.  "second paragraph" becomes 
"third paragraph" in the "Entry" box.)  Click OK > Close. (The "Edit Index Entry" 
window closes.)

3. Right-click in the Table of Contents.  Click Update Index/Table. (The entry is now 
"third paragraph" in the Table of Contents.  To change "second paragraph" to third 
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paragraph in your document, highlight "second paragraph" and type "third paragraph".)
4. Place the cursor immediately in front of the index entry in your document, third 

paragraph.  Right-click.  Click Index Entry.   ("third paragraph" appears in the "Entry" 
box.)  Click Delete.

5.  The next Index Entry,  "first paragraph" appears in the Entry box. Click Delete. 
(The "Edit Index Entry" window closes.)

6. Right-click in the Table of Contents. Click Update Index/Table. ("First paragraph 
and third paragraph" are no longer in the Table of Contents".)

Add Hyperlinks To The Table Of Contents
When a word(s) in the Table of Contents is clicked, the cursor will go to where that 
information is found.  For example.  “Add Hyperlinks to the Table of Contents” will be in the 
Table of Contents of this tutorial.  When in the Table of Contents and the words “Add 
Hyperlinks to the Table of Contents” are clicked, the cursor will go to this section on this page.

If you have NOT inserted a Table of Contents
1. Click after the last word in the title of the document.  (The Insert Index/Table window 

appears.)   Select the Index/ Table tab, if it is not already selected.  In the “Type” 
dialog  box , select Table Of Contents, if it is not already selected.  Uncheck 
Protected against manual changes.  Click OK.

2. To make the hyperlinks, click the Entries tab of the window, click to the left of the E 
and click Hyperlink, and click after the E and click Hyperlink again. Click All. Click 
OK. (The "Table "of Contents appears.  All the headings are in "blue and underlined" 
and are now "hyperlinks".  When you click on them, you will be taken to that section.)
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If you have already inserted the Table of Contents
1. Place the cursor anywhere in the Table of Contents and right-click.  (A menu will 

appear,)  Click Edit Index/table.   (The Insert Index/Table window appears.)  
2. To make the hyperlinks, click the Entries tab of the window, click to the left of the E 

and click Hyperlink, and click after the E and click Hyperlink again. Click All. Click 
OK.

3. After doing Step 2 , you will need to right-click in the Table of Contents and click 
Update Index/Table.  Be careful not to click any of the hyperlinked text in the Table of 
Contents.  Clicking on a blank space between the text and the page numbers is usually 
best.  (The "Table "of Contents appears.  All the headings are in "blue and underlined" 
and are now "hyperlinks".  When you click on them, you will be taken to that section.)

Additional Help
There is additional information on the Table of Contents within OpenOffice in the 
OpenOffice.org Help.  To access that information, do the following:

1. On the Menu Bar, click Help.  (A menu appears.)
2. Click Contents.  (The "OpenOffice.org Help” window appears.)
3. In the dialog box towards the top of the screen, select Help about OpenOffice.org 

Writer, if it is not already selected.
4. Click on the Index tab.

5. In the box, under the words, “Search term”, type the word, creating.   Click table of 
contents.  Click on the Display button (There will be several items listing under 
"creating".  The Display button is located at the bottom right hand corner.  Information 
about a Table Of Contents appears on the right side of the screen.)

6. Close the OpenOffice.org Help window. (Click on the X in the upper right corner of the 
"Help" window.)

Save File For Future Use
1. Click File > Save As.
2. In “File name:” box, type TOC_Lesson_1 .  (The name of the file will be 

“TOC_Lesson_1" . "TOC_Lesson_1.odt" appears at the top of the screen.)
3. Click File > Close. (The document is no longer on the screen.)

Note

Tutorials are improved by input from users. We solicit your constructive criticism. 

E-mail suggestions and comments to tutorialsforopenoffice@yahoo.com 

For other free tutorials go to: www.tutorialsforopenoffice.org 
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Edited by Sue Barron 
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